I'll second the request from kingswindsor. I need to update Plex but have hit a dead-end because my Vortexbox Fedora version is too old. I love my Vortexbox...