Announcement

Collapse
No announcement yet.

2 disc install SSD + HD

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2 disc install SSD + HD

    Hi there,

    i love Vortexbox!

    I'm building the third in my line of VBoxes and am looking for better Plex performance.

    As such I'd like to keep /storage on the HD and the OS and any transcribing on the SSD.

    VBox is installed on the SSD and the HD has a fresh 3GB partition.

    Before I start I wanted to check the best approach.

    Would it be a modified version of the USB external drive approach here?
    http://wiki.vortexbox.org/how_to_use...ve_for_storage

    Thanks,

    joe (mr)

  • #2
    Hi Joe and welcome back. I hope that was a typo of the 3GB HD and you meant 3TB (can't store many movies on 3GB). I have a VBA dedicated for Music only and another one dedicated for PLEX/Movies only due to how large both my music and movie libraries are. So if it were me, I would follow the multiple drive install in the Wiki which works great for a dedicated SSD OS drive and separate data drives. It works well with PLEX and I have no stalls or buffering ever.

    http://wiki.vortexbox.org/how_do_i_a...o_my_vortexbox

    Of course if this generates additional questions, just ask away. Hope this helps.

    Comment


    • #3
      Hi Transporter,

      I'm in the process of resurrecting my vortexbox instance after a hardware failure. I'm hoping to do as I think Joe was - have a separate HD for the /storage partition, which is how my previous install was configured. The link you refer to spans the /storage partition across both the 1st OS HD and 2nd HD rather keeping them separate.

      I recall the previous wiki had both sets of instructions, do you happen to know how best to simply repoint the storage partition to the 2nd HD?

      Cheers
      James

      Comment


      • #4
        You are right, these instructions where in the famous/legendary lost forums and wiki (I also configured my system this way).

        Take a look at this thread: https://www.vortexbox.org/forum/supp...-installing-vb



        Trying to reconstruct the instructions with the present wiki and forum I think the correct procedure is:

        First: install Vortexbox from an image
        but use:
        Code:
        config_4-fill.sh
        to fill the primary OS ssd/hdd (instead of config_4-30.sh).

        Then proceed with: http://wiki.vortexbox.org/how_do_i_a...o_my_vortexbox
        to mount the seperate drive(s) at /storage



        cheers
        /bart
        Last edited by bart; 08-04-2017, 05:14 AM.

        Comment


        • #5
          Hi there,

          Old Vortexbox user here but Linux noob.

          Just got some new hardware and I am attempting to follow the instructions above as i want to build my new 2.4 Vortexbox server with the operating system on 60 Gb SSD and a separate 3 Gb HDD for /storage.
          I want to keep them separate.

          But am confused as to exactly what i need to do and when...

          Install fine as per installation instructions http://wiki.vortexbox.org/vortexbox_...n_instructions

          Code:
           
           dnf -y update
          Code:
          config_4-fill.sh
          Do i need to still run to set up storage? Surely that tries to set up original ssd?
          Code:
            
           config_local_storage.sh
          Instruction http://wiki.vortexbox.org/how_do_i_a...o_my_vortexbox then tells me how to install a second hdd but only if iam adding to a drive not installing one new. Does anyone have a step by step installation instruction? Many thanks in advance



          Comment


          • #6
            https://web.archive.org/web/20151229...twodiskinstall

            Comment


            • #7
              I have a similar request to that set out in the comments above. I have an ageing VB2.3 host with 64bit support (VB installed on an SSD and a separate drive set up as /storage) that has started playing up and before condemning the mother board, I was planning a clean installation of 2.4 onto the SSD but would like to preserve the contents of the current /storage drive rather than restore from backup. I did a similar rebuild of the 2.3 box a few years ago when I replaced the boot SSD with a new one.

              It is easy enough to disconnect the second drive while installing 2.4 to the SSD. What I'm not clear on is what steps I do not need to do as the second drive already has a file system etc on it and just needs to be added as /storage on the new build.

              I'd also like to preserve some of the original config such as ripit settings and Bliss. I'm happy to let LMS rebuild the library as this does not take too long anyway. Other settings such as player config I can cover with a simple screen shot or text files that I can copy and paste settings into.

              Any ideas on what else can and cannot be (or isn't worth) carrying over to the new version? When I did the original rebuild of 2.3, there was a really handy guide on the old forums about copying some of the system config settings to re-import after the rebuild. I appreciate that some of that may not apply when going from 2.3 to 2.4 but any useful info that other users can provide would be much appreciated...

              Comment


              • #8
                Originally posted by Arcticpollen View Post
                ... Any ideas on what else can and cannot be (or isn't worth) carrying over to the new version? When I did the original rebuild of 2.3, there was a really handy guide on the old forums about copying some of the system config settings to re-import after the rebuild. I appreciate that some of that may not apply when going from 2.3 to 2.4 but any useful info that other users can provide would be much appreciated...
                Some of the old wiki is traceable on the Wayback Machine:
                https://web.archive.org/web/20160102...ge=upgrade-2.3

                preinstall-2.3
                postinstall-2.3

                Be aware that some things (paths) have changed since, so it can occur that your saved/restored pref setting will cause an error,
                For instance: on mine I was not able to get the Bandcamp plugging working anymore, it took some time to realize I had to manually clear/delete the cache (instead of copying back and forth).

                cheers
                /bart

                Comment


                • #9
                  Thanks for digging out the old archive copies of the pages. That worked a charm - I wasn't bothered about the Plex and LMS config as they rebuild pretty quickly. Now have a rebuilt and patched VB2.4. I've reconnected the second drive and switched /storage to point to it by editing /etc/fstab with

                  Code:
                   
                   /dev/StorageVM/lv_storage       /storage        ext4    defaults        2 2
                  Just need to get LMS to play through the USB DAC on my Oppo now...

                  Comment

                  Working...
                  X