Announcement

Collapse
No announcement yet.

Windows Can't See VortexBox Computer

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows Can't See VortexBox Computer

    I am using an older 2TB VortexBox appliance that I upgraded last year to version 2.4. It is wired to the router. The SB Touch is also wired. The SB radio is wireless. All this is working just fine.

    My problem is with Windows. Before and after the 2.4 upgrade I was able to see the VortexBox as a computer in the Windows WORKGROUP network map automagically. Recently, the VB has disappeared from the network map for no apparent reason and I cannot get it back. I can still see LMS and both SB devices in the Windows network map. I can get to the VB web interface if I type in the IP address, but not if I type http://vortexbox.

    I thought this was a Windows 10 problem until I obtained a second computer running Windows 7 only to find it behaving in the same manner.

    The Windows machines can see each other, but neither sees the VortexBox. The SB devices access the LMS just fine, but I have new music on the Windows machines I would like to upload to LMS and I know no way to do it other than to access the VortexBox folders via Windows..

    If anyone has solved a similar problem or has any advice it would be most appreciated.


  • #2
    Try mapping a network drive. In Windows file explorer, right click on This PC and select Map Network Drive. Then browse to the VB and select files. VB will show up as a drive under This PC.

    Comment


    • #3
      Thanks for your response, jimmi.

      Unfortunately, I cannot map a network drive to the VB because Windows does not see the VB in the "browse" box -- just as it does not see it in the network map.
      Last edited by whistler; 05-30-2017, 10:44 AM.

      Comment


      • #4
        Some time ago I had a similar problem and IIRC it was related to a Samba issue. Are you able to access the VB through SSH with Putty or similar? If so try these commands...
        Code:
        systemctl -l status smb
        systemctl -l status nmb
        If the processes are "inactive (dead)", start them by
        Code:
        systemctl start smb
        systemctl start nmb
        then recheck the status of each process. If the status shows "active (running)", Samba should be good to go.

        Comment


        • #5
          type win+R and enter \\<iip address>

          Comment


          • #6
            Thanks for your suggestion, jimmi.

            These are the results I got from the" systemctl -l status smb" command:
            & smb.service - Samba SMB Daemon
            Loaded: loaded (/usr/lib/systemd/system/smb.service; enable; vendor present: disabled)
            Active: failed (Result: core-dump) since Tue 2017-05-30 20:04:09 CDT; 3min 35s ago
            Process: 642 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=dumped, signal-BUS)
            Main PID 642 (code-dumped, signal-BUS)

            May 30 20:03:59 vortexbox systemd[l]: Starting Samba SMB Daemon...
            May 30 20:04:09 vortexbox systemd[l]: smb.service: Main process existed, code=dumped, status=7/BUS
            May 30 20:04:09 vortexbox systemd[l]: Failed to start Samba SMB Daemon
            May 30 20:04:09 vortexbox systemd[l]: smb.service: unit entered failed state.
            May 30 20:04:09 vortexbox systemd[l]: smb service: Failed with result 'core-dump'.
            May 30 20:04:22 vortexbox systemd-coredump[656]: Process 642 (smbd) of user 0 dumped core

            Stack trace of thread 642:
            #0 0x00007fa0852f7660 frame_dummy (libcli-smb-common-samaba4.so)

            I suspect this is not what it should be, but I don't really know. The results from the "nmb" command looked similar.

            Any suggestions?

            Comment


            • #7
              Agillis - Thanks for your input. Your suggestion takes me to the VB web interface. Unfortunately it does not let me get to the VB folders.

              Comment


              • #8
                I'm afraid I can't help further with the Samba issue. I don't know why Samba won't start. There were a lot of helpful posts about issues such as this that were lost when Andrews servers went down. Concerning Andrew's suggestion, on my Windows 10 machine that takes me to the VB server and I can see and access my music files. It does not take me to the VB GUI?
                One other thing to check...make sure the Workgroup name that shows in the VB GUI Network Configuration still matches the Workgroup name of your PC. In File Explorer, right click on This PC and bring up properties to check the name.

                Comment


                • #9
                  In windows file explorer typing \\vortexbox in the address bar should take you to your vortexbox file system ?

                  Comment


                  • #10
                    Originally posted by whistler View Post
                    Agillis - Thanks for your input. Your suggestion takes me to the VB web interface. Unfortunately it does not let me get to the VB folders.
                    I suspect you used // not \\

                    Comment


                    • #11
                      Thanks, tkr001. I was indeed mixing up // and \\.

                      When I follow Andrew's suggestion ("type win+R and enter \\<iip address>") with the correct slashes, Windows churns for a good while, a minute or more, and then comes back with:

                      "Windows cannot access <ip address>"

                      But in its response, Windows also provides a button labeled "Diagnose". If I click the Diagnose button, Windows then comes back with this message:
                      The remote device or resource won't accept the connection. The device or resource (<IP address>) is not set up to accept communications on port "The File and printer sharing (SMB)",

                      So . . . . it seems to me that this may well be a Linux problem rather than a Windows problem. Am I interpreting this correctly? Unfortunately, I have no Linux knowledge.

                      Is there an alternative short of reloading 2.4 from scratch? Would a reload from scratch even fix the problem?

                      Sorry guys. I am at your mercy.

                      Comment


                      • #12
                        Just a quick SWAQ at this since I'm not in front of your PC, what are your security settings on your Windows PC? Do you have File Sharing turned ON in Windows?

                        Also what is the Local Network setup? I believe your VBA is Ethernet to the Router, is the Windows PC wireless or on Ethernet? If it's Ethernet there can be no router issues, if WiFi if the following doesn't work, we might need to look at the router also.

                        I am assuming everything is connected properly and if you are able to stream to your SB Touch and SB Radio, the VBA is working properly on the network. Which would bring me back to the Windows PC not being able to log into the VBA with that being an issue with the Windows PC.

                        So first things first. Do a "dnf -y update" on your Vortexbox. Next, again from the CMD Line type
                        fix_network rebuild reboot Next reboot the Windows PC. Next find the Local Network IP Address of your Vortexbox again from the CMD Line type ifconfig to get the address of your Vortexbox. Now open a browser window on your network connected Windows PC and type the ip address the Vortexbox showed as its Local Network IP Address. If this doesn't open the Vortexbox Box GUI on the Windows PC after hitting Enter, try <vortexbox IP Address>:9000 example 192.168.0.25:9000 (of course with the 192.168.0.25 being YOUR actual VBA ip address) then hit enter, if that doesn't open an LMS GUI then we need to do a lot more troubleshooting. If you can now get to either the VBA GUI or LMS GUI, its time to check the Windows PC to make sure File Sharing is turned ON, then attempt to see if Windows File Explorer (hold Down Windows Key and Press E at the same time) can see the Vortexbox and its directory file system. Next let us know at what point this failed or if its now fixed.

                        Comment


                        • #13
                          Thanks for your response, Transporter!

                          In answer to your questions:

                          The network is as follows
                          • VBA Ethernet to router
                          • SB Touch Ethernet to router
                          • SB Radio wireless
                          • Windows 10 Desktop wireless
                          • Windows 7 Laptop wireless
                          • Various other devices all wireless (2 Google Pixel phones, 2 Chromecasts, 1 Samsung Smart TV, 1 i-pad)
                          Network discovery and file sharing are turned on in both Windows computers

                          I can successfully do all of the following:
                          • Access the Vortexbox GUI by typing its IP address into a browser
                          • Access the LMS GUI by typing its IP address into a browser OR by clicking its icon in Windows File Explorer OR by clicking its icon in the VB GUI
                          • See icons in Windows File Explorer for the other devices on the network including the router
                          • Access each Windows computer from the other Windows computer
                          • Play music or internet radio on the SBT and the SBR from the LMS server
                          • Stream media to the Chromecasts, the Smart TV, the computers, the phones and the ipad
                          • Use the VB backup feature from the VB GUI.
                          • Shut down or reboot the VB from the VB GUI.
                          • Putty into the VB from the Windows computers.
                          I cannot successfully do any of the following:
                          • See in Windows File Explorer an icon representing the VB
                          • See or access the files or file folders on the VB from the Windows computers either using Windows File Explorer or through a browser or by the “win+R and enter \\<iip address>” method
                          • Access the VB GUI by substituting the word “vortexbox” for the actual IP address
                          I used Putty to enter the commands you suggested. I have attached a file with a couple of screenshots because there were some error messages. I cannot discern any changes to what i can or cannot do on the network since entering the commands.and rebooting the computers.

                          Based on the error message I got when I entered the "systemctl -l status smb" command (see post #6) I am concerned that Samba is not working properly, but that is little more than a wild-ass guess because I know zilch about it.
                          Thank you all for your patience with my problem and my ignorance!!
                          Attached Files

                          Comment


                          • #14
                            The PDF attachment in my previous post does not seem to work. So . . . .

                            Here is the end of the results of the "dnf -y update" command" (see post 12). I don't know if the curl error is relevant.

                            Install 6 Packages
                            Upgrade 176 Packages

                            Total download size: 229 M

                            Downloading Packages:

                            The downloaded packages were saved in cache until the next successful transaction.

                            You can remove cached packages by executing 'dnf clean packages'.

                            Error: Error downloading packages:

                            Curl error (6): Couldn't resolve host name for https://mirrors.fedoraproject.org/me...23&arch=x86_64 (Could not resolve host: mirrors.fedoraproject.org)


                            Here is the results of the "fix_network rebuild reboot" command (see post 12): I don't know what "rebuild a bad network config" means.
                            ---------------------------------------
                            Network fix
                            dhcp - reset eth0 to dhcp
                            rebuild - rebuild a bad network config
                            ---------------------------------------

                            06/03/2017 20:47:23 - Rebuilding eth0 network config...
                            06/03/2017 20:47:25 - Done...
                            Attached Files
                            Last edited by whistler; 06-04-2017, 10:46 AM.

                            Comment


                            • #15
                              Wow, that was a bunch of installs and upgrades needed. When was the last time since you Built this VBA that you did a dnf -y update or clicked on the Upgrade button in the VBA GUI (of course other the the one you just did above)?

                              Looks like the network rebuild went fine. I can't say the same for attempting the dnf update. It looks like there wasn't an Internet connection for the full amount of time needed or that the Mirror was off-line at the time. I would do a "dnf clean all" followed by a "dnf -y update". This will clear out all the caches and clean everything up, then install everything that is needed without any interference from what might be cached but not actually completed or hung. Let us know if there are errors after trying this. Looking back over what you did try, it does appear that Samba is not started and running. After doing the (clean all & update), reboot so all processes should be started, then use Windows File Explorer to see if you see your VB and its file structure (you should actually see two, a read only, and the actual files that you can edit and move). Also when using Windows File Explorer, open the lowest listed Servers. You will probably see a VB up by your other network devices but these are usually the read only files depending on how the Network is set up and down at the very bottom of the list you will see Local Items, click on this and it should again show a VB and any other Server or PC on the network. Open up this file change should get you to the actual read/write files. If its still No Joy, run the Samba check from above to look at the status to make sure Samba is in fact running and available.

                              Comment

                              Working...
                              X