Announcement

Collapse
No announcement yet.

Qobuz artwork has gone missing in LMS 7.9.0. How to update to 7.9.1 nightly?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Qobuz artwork has gone missing in LMS 7.9.0. How to update to 7.9.1 nightly?

    I am running Vortexbox 2.4 with the standard LMS, currently 7.9.0.

    Last week Qobuz changed something with the artwork on their servers, something to do with changing from HTTP to secure HTTP I understand. However doing that they managed to screw up the Qobuz plugin on the LMS server. So now the album artwork is no longer displayed in LMS.

    I posted about this over on the Squeezebox forum:-

    http://forums.slimdevices.com/showth...g-in-favorites

    It seems that the issue had been fixed in the latest nightly of LMS 7.9.1. However that still leaves me with the problem of the missing artwork as I have no idea how I can install the latest nightly build of LMS on my vortexbox without screwing things up.

    I have looked in the WIKI ,but there is only a guide on how to install the latest LMS on a vortexbox 2.3.

    Is there anyone that can advise me on what I should do please?

    Thanks for your help.

  • #2
    Instructions for VBA 2.4 are directly below the 2.3 instructions keep scrolling down. But that might not solve your problem as what is in the Community Repository isn't last Night's Nightly.

    http://wiki.vortexbox.org/how_to_ins...ity_repository

    If it were me, I would deal with no Art Work until the "Fix" is in the stable version available by the Upgrade Button in the VBA GUI. I don't mind using Nightlies on a Windows PC because falling back to the Stable release or the previous Nightly isn't that hard. IIRC, the only falling back with the VBA would be to the latest Stable release in the VBA Repository NOT the Squeezebox Community Repository.

    Comment


    • #3
      Thanks for your reply. Your advice is good, I will wait until there is an oficial stable release.

      Comment


      • #4
        The Squeeze Community Repo is no longer updated and should be ignored.The nightly LMS builds are still readily available and I can provide the steps if you're interested in changing to 7.9.1. If you do, you can no longer use the VB GUI to Update via the web interface, since it will revert LMS to the VB 7.9 version. You need to update using a simple command line code....not a big deal since there are few if any update for Fedora or VB 2.4.

        Comment


        • #5
          Originally posted by jimmi View Post
          The Squeeze Community Repo is no longer updated and should be ignored. The nightly LMS builds are still readily available and I can provide the steps if you're interested in changing to 7.9.1.

          @ Jimmi If you would be so kind as to provide those commands, I will update the Wiki so they are added and available for anybody looking to run Nightlies.

          Comment


          • #6
            Originally posted by Transporter View Post


            @ Jimmi If you would be so kind as to provide those commands, I will update the Wiki so they are added and available for anybody looking to run Nightlies.
            This was originally provided by Ron Olson, who has contributed so much to the forum over the years.
            How to Update to an LMS nightly:

            1. Remove the VortexBox version of LMS:
            Code:
            rpm -e --nodeps logitechmediaserver logitechmediaserver-CPAN logitechmediaserver-vendor logitechmediaserver-firmware-ip3k
            2. Restore the LMS server.prefs file:
            Code:
            cp -a /var/lib/squeezeboxserver/prefs/server.prefs.rpmsave /var/lib/squeezeboxserver/prefs/server.prefs
            3. Install LMS from the Slim Devices nightly:
            Code:
            dnf install  http://downloads.slimdevices.com/nightly/7.9/sc/55045f0/logitechmediaserver-7.9.1-0.1.1495659078.noarch.rpm
            This is the latest version as of June 6, 2017. If you install on a later date, pick up the RedHat rpm version that's in http://downloads.slimdevices.com/nightly/?ver=7.9

            4. Link required perl library:

            Code:
             
             ln -s /usr/lib/perl5/vendor_perl/Slim /usr/lib64/perl5/vendor_perl/Slim
            5. Restart LMS:

            Code:
             
             systemctl start squeezeboxserver
            6. Check LMS status:

            Code:
             
             systemctl -l status squeezeboxserver
            7. You will have to upgrade your VB 2.4 system from the command line to prevent the Slim Devices nightly LMS from being upgraded to the VortexBox version:

            Code:
            dnf clean all; dnf --exclude=logitechmediaserver* update

            Comment

            Working...
            X