Announcement

Collapse
No announcement yet.

dotnet needed for new Roon version

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • dotnet needed for new Roon version

    Hello. An email just went out to Roon users who use the Linux version that in November an update is being pushed out that requires the dotnet framework to be part of the Linux base OS.

    I'm running Roon Core on top of the Vortexbox 2.5 OS and have absolutely no issues. However, it seems that the Microsoft dotnet framework is not included as part of the Fedora version underlying VB 2.5

    How can I add this - or can I?

  • #2
    The email from Roon gives a link to the necessary linux commands,
    apt-get update && sudo apt-get install libicu66,
    although this needs some modifying for Fedora as apt-get needs to be replaced by dnf.

    I'm no linux expert but this is what I used;
    dnf - y update
    sudo dnf install libicu66
    dnf clean all

    Comment


    • #3
      Ah, so libicu66 is the installation files, thanks. I read that mail as that being a version of Linux. I'm farther from a Linux expert than you are, obviously!

      By the way, those commends do not work in the Vortexbox 2.5 installation. I likely need to map a new repro location.

      libicu66 is not in the Fedora 25 repository, by the way, so I used this command:

      Code:
      dnf config-manager --add-repo http://mirrors.kernel.org/fedora-buffet/archive/fedora/linux/releases/29/Everything/x86_64/os/
      update: nope, no luck. No package available.
      Last edited by dyohn; 10-19-2021, 06:37 PM.

      Comment


      • #4
        I found this information but I am not sure how to use it yet...

        http://rpm.pbone.net/info_idpl_48769...m.html#content
        Last edited by dyohn; 10-19-2021, 09:05 PM.

        Comment


        • #5
          dyohn- you are correct libicu66 is not found, my mstake.

          there are some install instructions here but only for Fedora 27 and later.
          https://docs.microsoft.com/en-us/dot...a#dependencies
          Last edited by EricJ; 10-20-2021, 09:42 AM.

          Comment


          • #6
            Make sure you are running VortexBox 2.5

            That will work well with new versions of Roon.

            Comment


            • #7
              Originally posted by agillis View Post
              Make sure you are running VortexBox 2.5

              That will work well with new versions of Roon.
              So you are saying there is no reason to follow Roon's suggestion and add libicu66?

              Comment


              • #8
                Watching this thread with much interest..

                Seems to be conflicting info?
                If I understand correctly from reading the Fedora site on dotnet, the oldest release it runs on is 27.
                Roon update is due 11/3, so anyone currently running roon on Vortexbox 2.5 (Fedora 25) should disable Roon updates until we get a definitive answer..

                Again, I really like the VB package and hope that it continues to be supported.

                Thanks
                CS

                Comment

                Working...
                X