Announcement

Collapse
No announcement yet.

Install doesn't create local storage volume so I can't extend to second or third disk

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Install doesn't create local storage volume so I can't extend to second or third disk

    Hi, Probably a newbie error here, but i'm hopeful that someone can point me in the right direction!

    I previously had a VBOX 2.4 install working on a 64gb SSD and 4tb HDD with no problems at all until I started running out of storage so I took the (possibly foolish) hit of getting 2x 6tb HDD's and setting up a new system, but no matter what I try I can't add either of the two 6tb drives - I initially thought it was a problem with the fedora 23 not being able to recognise the size, so I tried an install directly onto one of the 6tb drives and it see the full size with no problem, I just can't expand the storage volume, which seems to stem from the same initial issue whereby the local storage volume is not created, despite running the
    HTML Code:
    config_local_storage.sh
    command.

    I followed the steps in the instructions to the letter (as with my previous install, but with no joy - can anyone offer any assistance at all?

    BTW: i've tried the advice from https://wiki.vortexbox.org/how_do_i_...o_my_vortexbox and https://www.vortexbox.org/forum/supp...sd-data-on-hdd to no avail (but assume they failed fue to a lack of local storage volume - it can't expand what doesn't exist!

    As a positive aside, in tinkering around trying to resolve the problem I managed to update the install to fedora 25 which also updated vortexbox to v2.5 as a result, allowing me to load the latest version of plex - so that's a winner, I just need the storage

    Also, are there any performance benefits in running a small SSD for the OS or is it simply best practive to keep the OS and data on separate volumes in case of failure/upgrade?

    Many thanks, in advance,
    Neil

  • #2
    Here's the series of commands I ran post initial install:

    HTML Code:
    dnf -y update
    
    config_4-30.sh
    (also tried config_4-fill.sh)
    config_local_storage.sh
    reboot
    
    config_lvm_drive.sh /dev/sdb
    config_add_lvm.sh /deb/sdb1
    reboot
    
    dnf install dnf-plugin-system-upgrade
    
    dnf -y system-upgrade download --releasever=25 --nogpgcheck --allowerasing
    
    dnf system-upgrade reboot
    
    dnf install https://downloads.plex.tv/plex-media-server-new/1.19.2.2702-776106bc6/redhat/plexmediaserver-1.19.2.2702-776106bc6.x86_64.rpm
    
    config_lvm_drive.sh /dev/sdb
    config_add_lvm.sh /deb/sdb1

    Comment


    • #3
      FYI - I have a friend who it turns out is a bit of a linux guru and he managed to sort it, so now it's up and running v2.5 on fedora 25 with 12TB of storage - happy days!

      Thanks for looking

      Comment

      Working...
      X