Announcement

Collapse
No announcement yet.

Trouble ripping dvds

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble ripping dvds

    I have been having trouble the last couple of months ripping dvds. I am on v2.3.
    Blood Father actually said it had created the MKV but is no sign of it in the folder.
    Can anyone help?

  • #2
    Ripping DSDs is not working at the moment.

    Comment


    • #3
      I have found a workaround that works for me for this issue if one is able to edit filenames directly from the CMD Line or VIA using Windows Explorer to link to your Vortexbox to rename the "title00.mkv" file after every rip.

      Workaround: One must either remove the Vortexbox Ethernet connection or turn off its WiFi connection. Load and rip a DVD as usual. When the disk ejects, the rip is finish. Now one MUST go into the /storage/movies directory and rename the "title00.mkv" file to the name of the movie just ripped. If editing via headless, one must reconnect the Ethernet cable so the Vortexbox is back on ones Network. As an example, if one just ripped The Godfather and it is now title00.mkv so rename it to "The_Godfather_(1972).mkv" (NOTE: the quotes are not used and yes I use a underscore between each word, the date in parenthesis helps PLEX and with remakes). Now that the file is renamed, one can remove the Ethernet cable again and rip another DVD which will again be named "title00.mkv" which one will again rename after the rip finishes, repeat.

      An alternate solution is to block IP Address 66.241.100.214 in ones router if you have the knowledge or ability. Once finished ripping remember to plug your Ethernet back in if using the CMD Line to edit the files so your music and movies are available via ones network.


      What is see happening is there are currently two calls being made during the ripping script that do not provide the proper reply answers (one actually fails with the URL 404 failure because the Vortexbox.org server isn't there anymore) so the script fails causing the TMP File being created not to be renamed then moved so since the TMP File doesn't get renamed and moved plus the script deletes the TMP file when finished, the rip was completed properly but gets deleted since it didn't get renamed and moved to /storage/movies directory.

      So give that a try until this is resolved and fixed. Basically with an Internet connect Vortexbox, once a week do a dnf update -y then try ripping a new DVD to see if the bug has been resolved in the repo. If it doesn't show in the directory, one will still need to use a workaround.

      Hope this works for others and somebody finds this helpful.

      Comment


      • #4
        Here are a couple workarounds that I have been using-
        After being ripped the mkv file is likely in /storage/tmp/ripper.tmp and named something like title00.mkv
        Similar to Transporter's workaround above I have just edited the filename to reflect a proper name for the movie and moved it to /storage/movies
        it will then get picked up properly for use.

        After a while this got old so seeing that the issue was the inability to reach a section of vortexbox.org (aka 66.241.100.214) that was offline I decided to add the IP to the firewall so that the system would just try to use the dvd name it was able to pull from the DVD media. This usually works adequately.
        You can do this from the command line as follows:
        # iptables -A INPUT -s 66.241.100.214 -j DROP
        After executing this the vortexbox.org IP is blocked and the DVD rip should work.

        Note 2 things about this workaround-
        1- the server will not be able to reach vortexbox.org for anything including updates while this is active
        2- I specifically did not make the entry permanent so if the server is rebooted the entry will no longer be active. So if the issue is fixed or you want the system to be able to reach vortexbox.org again you just need to reboot the box and things will revert to normal. (if you want to firewall the IP again you will need to run the command again after rebooting)

        hope this helps
        -Mark

        Comment


        • #5
          Nice Workaround Mark! I forgot to tell Users if they did the IP Block (using Router or CMD Line) that they would not get the "title00.mkv" file name but usually some semblance of the Movie Title and could immediately edit it because the Vortexbox was still connected to ones Network if editing via headless. Also using the Firewall instead of the Router to block the IP is easy for anybody that can use the CMD Line and eliminates trying to explain 50 different Router Manufacturers' procedure to block an IP Address. Having an RF Engineering background and being a retired Cellular Network Engineer, I am always thinking about blocking unwanted traffic as far away from internal networks as possible (first outside connection) and not thinking about the ease of just using the CMD Line. Thanks for tidying up and posting.

          Comment


          • #6
            Latest WorkAround for the current MakeMKV issues for Beta Key MakeMKV Users (don't believe this effects users that purchased a Key):

            If your are getting this error "This application version is to old. Please download the latest version or enter a registration key to continue using the current version." and the new MakeMKV Key has still not been issued yet, try changing the date and time from the CMD Line:

            date -s '2017-03-20 02:00:00'

            iptables -A INPUT -s 66.241.100.214 -j DROP

            This will set the date of the Vortexbox back to 2AM on March 20th when the Key is still good for the current MakeMKV version. NOTE: one does an ENTER/Return at the end of each line (last time I typed Return somebody kept typing in the word 'return'). Also the date and time are bracketed by the ' grave mark and not quotation marks. The second line (hat tip MarkDan) prevents the Name Search via the offline IP Address that causes the ripping script to fail.

            Lastly note that changing the system time in the BIOS might not work but doing the CMD Line does work for sure. I shutdown my Vortexbox and changed my system time at start-up and it shows that new older date/time in the GUI Window when the ripper initializes, but right before the actual ripping starts it shows the actual current time and the rip fails out with the Key Expired error. I checked the BIOS Date and it was still March 15th were I set it but doing a "date" command with the CMD Line showed the actual current time. So I changed the date and time via the CMD Line and I can currently rip DVDs.

            Comment


            • #7
              Thanks for the workarounds. I have actually only just go around to taking a look at fixing this, but did a software upgrade before attempting it. Blood Father has now ripped, albeit into a number of subfolders so I had to rename and then move it. I might go back and try some others that did not rip prior to this and see if they now do.

              Comment


              • #8
                Andrew:

                Any update on fixing the DVD Ripping Process? I have checked and pulled down all current versions and updates. Did a Clean All, then rebooted. The process still fails to move the completed ripped DVD file to /storage/movies, it leaves the file in /storage/tmp/ripper.tmp which if one inserts another DVD to rip, it is ripped and writes over the last rip if it is not manually moved to /storage/movies after every rip. This is not overly effecting me as I can rip on my laptop and have the file ripped to //vortexbox/storage/movie as destination, but my friends that I have turned onto Vortexbox because they know nothing about networks, ripping, or anything technical and hence love the Auto-ripper feature of just "Feeding" the Vortexbox CDs or DVDs can no longer get DVDs onto their Vortexbox because they can't use the CMD Line or figure out how to use Windows File Explorer to move the file from /storage/tmp/ripper.tmp before ripping another DVD.

                It appears that modifying just a few lines of code could probably fix this issue from what I have watched during the actual ripping.

                Comment


                • #9
                  Thought i'd register here just to post the fix... use your favorite editor to modify /opt/vortexbox/getdvdname.php Just comment out the two lines that mention api.vortexbox.org.

                  Comment


                  • #10
                    Hello,

                    I'm experiencing the inability to rip/store DVD's on my VBA, I'm running V2.3 on Fedora20.

                    I've worked my way through this thread and altering the date as recommended via CL. No joy. I got the following report in the ripper dialogue...

                    MakeMKV v1.9.10 linux(x86-release) started Current operation: Scanning CD-ROM devices Current action: Scanning CD-ROM devices Current progress - 0% , Total progress - 0% Current progress - 0% , Total progress - 0% Current progress - 100% , Total progress - 0% Current progress - 100% , Total progress - 100% The new version 1.10.6 is available for download at http://www.makemkv.com/download/ This application version is too old. Please download the latest version at http://www.makemkv.com/ or enter a registration key to continue using the current version. Ripping took 2 minutes and 50 seconds. 03/20/2017 02:06:11 - Done." Are there any known fixes yet? I miss not being able to rip and stream music DVD's to my Laptop *sobs quietly into wine glass*!

                    Comment


                    • #11
                      Welcome Dave. MakeMKV is fixed and is no longer the issue. You must either use the workarounds above (other then those for MakeMKV) or you need to use NANO to "edit" out the two calls to the Vortexbox.org Server. The other option is to download MakeMVK unto a Windows PC/Laptop and use it to rip your DVDs. If its on the same network as your Vortexbox and both are Ethernet connected, you can have MakeMKV put the ripped movie directly on your Vortexbox by changing the destination. Note if you use MakeMKV on another PC, you must change the name of the Movie after every Rip as it will be named title001.mvk by default each time.

                      Comment


                      • #12
                        Hi Mr Transporter!

                        Ah, pity I can't get VBA to just rip and tag DVD's like it used to, meh! I wondered if my version of VB was out of date as it never seems to update thesedays either when I manually try and 'update package'.

                        OK, I'll DL MakeMKV onto a networked PC and have a go at ripping and sending them to VBA over the Wifi network.

                        Ta for the advice BTW.

                        Cheers.

                        Comment


                        • #13
                          Ooo! For the 1st time in over a year my VBA has updated. The latest LMS is amongst the updates, whahey! I think it must have worked out we were talking about it

                          Comment


                          • #14
                            Has there been any progress on fixing the dvdinfo.php api endpoint?

                            For now I've got my vortexbox ripping DVD's again by modifying the "getdvdinfo" function in /opt/vortexbox/getdvdname.php
                            I added a check to the http status code before processing the result if it isn't 200 then the movie will be called "MovieUnkown".
                            You'll still need to manually rename the file but it will copy out of the ripper.tmp folder automatically. Ripping multiple discs will then have the usual effect of adding the unix time stamp onto the file name.

                            Seems to work alright but would be much nicer to get the auto renaming working again.


                            Code:
                            function getdvdinfo($dvdid) {
                                    $dvdidurl = substr($dvdid,0,8).substr($dvdid,9,8);
                                    $curl_connection = curl_init ("http://api.vortexbox.org/dvdinfo.php?dvdid=".$dvdidurl) ;
                                    curl_setopt ($curl_connection, CURLOPT_RETURNTRANSFER, 1) ;
                            //      curl_setopt($curl_connection, CURLOPT_VERBOSE, 1);
                                    curl_setopt($curl_connection, CURLOPT_HEADER, 1);
                                    $response = curl_exec ($curl_connection) ;
                                    $header_size = curl_getinfo($curl_connection, CURLINFO_HEADER_SIZE);
                                    $header = substr($response, 0, $header_size);
                                    $body = substr($response, $header_size);
                                    $status_code = curl_getinfo($curl_connection, CURLINFO_HTTP_CODE);
                                    if($status_code != 200){
                                            $dvdtitle = "MovieUnknown";
                            //                echo "non 200 code getting dvd title. Set to unknown";
                                    }else{
                                            $dvdtitle = $body;
                                    }
                                    curl_close ($curl_connection) ;
                                    return $dvdtitle;
                            }

                            Comment


                            • #15
                              Simon, this worked great for me Thanks so much!

                              Comment

                              Working...
                              X