Announcement

Collapse
No announcement yet.

Can't upgrade Vortexbox

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't upgrade Vortexbox

    Hi,

    I am unable to upgrade my Vortexbox from the web interface: I get the following error.

    12/17/2018 07:41:32 - Starting upgrade. (This can take a long time...)

    [Errno 2] No such file or directory: '/var/cache/dnf/metadata_lock.pid'
    12/17/2018 07:41:34 - Error: dnf update failed. Check error messages and try to fix problems.
    0 files removed
    Dependencies resolved.
    Nothing to do.

    My system info is

    VortexBox SW Version: 2.4

    Linux OS Version: Fedora release 23 (Twenty Three)

    Apologies if this has come up before; I upgrade rarely, since the VB works well and doesn't need much attention, as a general thing.

    Thanks much.

    Nike

  • #2
    I can't help you with that specific error message. But, since Fedora 23 is well past it's end of life date and is no longer supported, there are no updates. Are you looking for a particular update for one of the add-on programs like LMS?

    Comment


    • #3
      Thanks. No, I was just doing some routine clean-up of my music and decided to run update.

      Is 2.4 on Fedora 23 the most recent version of the Vortexbox software? I was not able to find anything later on the Wiki. That version is the only one listed on the installation guide here:

      https://wiki.vortexbox.org/installation_guide

      Or is the Vortexbox software just not supported any more?

      Comment


      • #4
        On further investigation, this seems to a GUI issue. It's possible to run def -y update manually from the terminal. There are other reports of this in the forum. The command completes without issue, but there don't seem to be any updates available. If any developers are looking at this (not sure if there is any active development any more) perhaps this could be fixed....

        Anyway, the system works, so I won't worry about it too much.

        Comment


        • #5
          Yes, VB 2.4 is the most recent. Andrew posted some time ago that a new version is in the works, but there is no hint of an intro date. He is selling players, etc through Small Green Computer but I don't think there is any reference to the program they use....current VB or something newer.

          Comment


          • #6
            Here the Steps I have done ...

            dnf -y update

            rem Upgrade to Fedora Ver.25 and Reinstalling plus Upgrading of the Vortexbox-Systems

            dnf upgrade --refresh
            dnf install dnf-plugin-system-upgrade
            dnf system-upgrade download --refresh --releasever=25
            dnf system-upgrade reboot

            rem Control of the Installation-Version after Reboot

            cat /etc/*-release

            rem Last Steps to clean the System


            dnf clean dbcache
            dnf clean expire-cache
            dnf clean metadata
            dnf clean packages
            dnf distro-sync
            dnf clean all
            dnf autoremove
            reboot

            Comment


            • #7
              Have you seen any downside to doing this?

              Are you using PLEX?
              Did it allow upgrade to current version?

              Are you using MAKEMKV for DVD Ripping?
              Did it allow upgrade to current version?

              What other Processes are you running: SqueezeBox, BLISS, Backup?

              Comment


              • #8
                The method detailed in post #6 works to install Fedora 25. My Vortexbox boots, and the Web interface loads, but, Squeezebox Server doesn't launch.

                As pointed out in another thread . https://www.vortexbox.org/forum/supp...rtexbox-access

                As far as I can tell, the only way out is to reinstall Fedora 23 and Vortexbox from the standard disk images.

                Comment


                • #9
                  There are a few threads running which give
                  • hints on starting LMS (a PERL command should sort - LucaBerta posted it).
                  • Once working it appears possible to get Fedora 25 (via yum) to kick the VB version up to 2.5 as well.

                  Comment

                  Working...
                  X