Announcement

Collapse
No announcement yet.

Folder and File names use the underscore (_) instead of a space ( )

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Folder and File names use the underscore (_) instead of a space ( )

    I was able to fix this problem in the past, but I guess after an upgrade the problem resurfaced. When I rip a cd to my Vortexbox the folders and file names use an underscore between words. I would like to be able to edit that so it will use a space instead. The reason this is important to me is because when I copy the songs to a USB drive to play in the car, the car announces each song by stating "underscore" repeatedly. I would really appreciate it if someone would post detailed instructions on how to edit the file and folder name procedure or direct me to instructions already posted somewhere. Thank you.

  • #2
    BLISS is a great tool to do this on the VB:
    https://www.blisshq.com/music-librar...-organisation/

    Comment


    • #3
      Thanks Vbbob but I dont use Bliss and I know there is a very similar command that you can input directly into the VB that will change the way folders and files are named. Anyone know it?

      Comment


      • #4
        jefrank,

        You have to edit the ripit config file
        In another thread jimmi posted a reply about editing this config file to stop creating .m3u playlists
        Originally posted by jimmi View Post
        The following are notes I saved from a post by Ron Olson about the .m3u files. I recall doing this on an earlier version of VB
        By default, the VB Auto Ripper creates a .m3u playlist file in each album directory. I have never found a use for these playlist files. Here's how to keep them from being generated:

        . Edit /etc/ripit/config:
        nano /etc/ripit/config

        . Change the line playlist=1 to playlist=0

        . Write the file (control-o) and exit (control-x).
        Restart the Auto Ripper: In a browser, go to the VB Auto Ripper page http://vortexbox/ripstatus.php, and click the "Restart Auto Ripper" button
        Looking at /etc/ripit/config you will find this directions (among many other options)
        Code:
        # underscore: Replace blanks in filenames with underscores
        # Possible values: 0 - off, 1 - on
        # Default: on
        
        underscore=1

        So you have to edit /etc/ripit/config following jimmi's saved notes:

        nano /etc/ripit/config
        Find the line
        underscore=1
        Change underscore=1 to underscore=0
        Write the file: control-o
        and exit: control-x
        Restart the Auto Ripper: In a browser, go to the VB Auto Ripper page http://vortexbox/ripstatus.php, and click the "Restart Auto Ripper" button



        Good luck, cheers
        /bart
        Last edited by bart; 12-18-2018, 02:16 PM.

        Comment


        • #5
          Thank you Bart, I will try it and let you know how it works.

          Comment


          • #6
            Bart, it worked like a charm. Thank you so much. One more request. The autoripper is writing (showing what it is writing in caps) ARTIST - SONGNAME.FLAC
            as the individual song file names. How would I change it to simply read SONGNAME.FLAC ?

            Comment

            Working...
            X