Announcement

Collapse
No announcement yet.

Installing Vortexbox 2.4 on a UEFI based system (Intel NUC DN2820FYKH)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • davem
    replied
    I also have the same NUC and running 2.3.

    I have successfully tinkered with 2.4 in the past. Successful in that it would boot and run but would not work properly using a USB stick as the system drive.

    Sounds to me that Transporter is on the right track.

    Leave a comment:


  • Transporter
    replied
    I have 3 of those Intel NUCs. I believe your BIOS update might be your problem. I will see if I can find the Linux Post that told me which updates could be used. If I remember correctly, anything over 48 or 52 can't be used with VBA 2.4. There is something turned on in higher BIOS versions that Fedora 23 doesn't like which VBA 2.4 is based on.

    Leave a comment:


  • velix
    replied
    The VortexBox 2.3 installation on SSD from the older NUC actually works in the new NUC (!), so I will keep this installation, any attempt to boot a 2.4. installation (made on the old NUC) failed to boot, unless there's USB (Boot from First Harddisk) as bootstrap.
    I don't want to upgrade install 2.5.1 because "bliss" won't work on that version.

    Leave a comment:


  • Wirrunna
    replied
    I suspect that you have run into a known problem where the boot kit that installs Vortexbox is a few years old now so doesn't have drivers for current hardware. This was mentioned in https://www.vortexbox.org/forum/main...newer-releases .

    As you mentioned that you have an older NUC, my advice is to install VBox 2.4 on an SSD attached to it and then upgrade to Fedora 25 using the steps here
    https://www.vortexbox.org/forum/main...=1433#post1433
    Then attach the SSD to your new NUC and boot up.

    Leave a comment:


  • pclinux1
    replied
    If you can access the uefi settings by pressing esc or F2 or delete [google how to do it] and then turn off secure boot/fast boot.

    Leave a comment:


  • Installing Vortexbox 2.4 on a UEFI based system (Intel NUC DN2820FYKH)

    This is my first post in this Forum, (maybe I'm too verbose.)

    I literally spent all last Saturday afternoon in desperately trying to install VortexBox 2.4 on Intel NUC DN2820FYKH.
    Maybe it was a mistake to update the BIOS first to latest Version 63.
    I managed to make the bootable VortexBox2.4 USB-Stick as installation media. But I had no chance of booting it into UEFI mode, so I booted it in Legacy mode, which worked first.
    It wrote the installation files of VortexBox2.4 correctly (see below, why), but in Legacy (nor UEFI) mode I could not boot from the SSD i had installed it on.

    The only way to start up the VortexBox installed on the SSD, was to boot from a different USB Media created on Windows using YUMI Multiboot installer, and then choose "Boot from first Harddisk". So, USB Sticks boot in Legacy and UEFI mode, but the Installation on the SSD can only start, when, given bootstrapping from USB drive, created using YUMI.
    Otherwise computer says: "Insert proper boot media and press Enter", when starting in Legacy mode from the SSD, while in UEFI Mode, the SSD isn't accepted or listed as boot device in BIOS.

    I tried "boot-repair" (from UBUNTU Live booted in UEFI mode), which has often saved my GRUB's , which failed, because UBUNTU is debian based and tried to execute fedora shell command lines via chroot.
    I tried the "boot-repair" Live CD, which failed, because I could not boot it into UEFI mode.

    Any ideas how to get the GRUB working, or is there an option to boot VortexBox2.4 installer into UEFI mode?
    BTW: I have a VortexBox 2.3 running on another (CPU-weaker) NUC, what if I upgrade it to 2.4 and put its SSD into the DN2820FYKH?
Working...
X