Announcement

Collapse
No announcement yet.

Spotty v1.9.4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spotty v1.9.4

    Trying to use Spotty v1.9.4 on my VB 2.2 (running Fedora Release 16) and LMS 7.8.0

    Installation notes state the following:

    * The plugin requires a few tools to be installed. In many cases they are part of the system. Please make sure you have "pv" (Pive Viewer), and either "curl" or "wget" installed on your system. Install using your operating system's package management tool if needed. They should be available on any Linux system.

    Trying to run Spotty 1.9.4 on my system confirms I'm missing this pipe viewer utility with no idea how to get/install this. Can someone please point me in the right direction to get pv and either "curl" or "wget" in case I don't have that as well

    [17-10-09 17:31:08.3070] Plugins::Spotty::Plugin::initPlugin (112) Please update to Logitech Media Server 7.9.1 if you want to use seeking in Spotify tracks. [17-10-09 17:31:08.5090] Plugins::Spotty::Connect::_getPVcmd (390) Didn't find the pv (pipe viewer) utility. Please install pv using your package manager Thanks

  • #2
    Two things. First, You'll need to install VB 2.3 in order to make Spotty work. It will not work with VB 2.2 or earlier. Second, the info about pv, curl, wget is all ONLY needed to use the "experimental" spotify connect function to work with LMS (which is different than simply having Spotify work on LMS and squeezeboxes). I didn't install any of that stuff, and Spotify works perfectly for me.
    Last edited by garym; 10-09-2017, 10:32 AM.

    Comment


    • #3
      Originally posted by garym View Post
      Two things. First, You'll need to install VB 2.3 in order to make Spotty work. It will not work with VB 2.2 or earlier. Second, the info about pv, curl, wget is all ONLY needed to use the "experimental" spotify connect function to work with LMS (which is different than simply having Spotify work on LMS and squeezeboxes). I didn't install any of that stuff, and Spotify works perfectly for me.
      Thanks garym I have an earlier version of Spotty on my system and while it works it runs for about 5 seconds followed by 3 seconds of buffering etc. Never had that issue with other Spotify plug-ins so I thought to upgrade to the latest Spotty to see whether this buffering issue is resolved. So while I'd like to (eventually) have Spotify connect the more pressing need is uninterrupted Spotify music

      Not sure about the requirement for VB2.3 but maybe this buffering is connected,

      Comment


      • #4
        No, it's not entirely about buffering. However, to make Spotty work correctly, you'll need VB 2.3. There's no way around this. Spotty finally drove me to update from VB 2.0 to VB 2.3. (according to michael at logitech, the author of Spotty, the issue is that VB 2.3 is the first 64bit version of vortexbox and this is required.)

        EDIT: I meant to say VB2.4 above, not 2.3
        Last edited by garym; 10-11-2017, 07:41 AM.

        Comment


        • #5
          Ok so it looks like the my days on VB 2.2 are finally counted . Thanks

          Comment


          • #6
            I understood that you need to upgrade to 2.4 in order to use Spotty - is it now functioning with 2.3?

            Comment


            • #7
              Sorry, I was doing this from memory. Correct: One needs the latest VB which is VB2.4 (not 2.3)

              Comment

              Working...
              X