Announcement

Collapse
No announcement yet.

Updated version of LMS released

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Viragored
    replied
    Originally posted by Viragored View Post

    I upgraded to VB2.5 and have now got a non-working system, details in post #19.

    Any help will be most welcome!.
    And with much regret I now say goodbye to Vortexbox, which I have mostly enjoyed having. I've put Windows onto the old computer, installed LMS and once more can listen to my music.

    Leave a comment:


  • Viragored
    replied
    Originally posted by agillis View Post
    We are only releasing new packages for 2.5. Anybody with lower versions should update to 2.5.
    I upgraded to VB2.5 and have now got a non-working system, details in post #19.

    Any help will be most welcome!.

    Leave a comment:


  • agillis
    replied
    We are only releasing new packages for 2.5. Anybody with lower versions should update to 2.5.

    Leave a comment:


  • Viragored
    replied
    I've run into a real oddity - can anyone help?
    I've installed VB2.5 onto my old PC, which booted up as expected. Using my Windows 10 PC I made a couple of changes over the network from the GUI (inc. static IP; region time), loaded a few tracks into /storage/music/flac, and LMS built a library. So far so good, and easy.
    Now I need to connect my Squeezebox Duet using the Android app "Squeezebox config", which has always worked fine alongside VB2.4. But as soon as I do that, the VB refuses all SSH and some other connections -
    • VB GUI won't connect in Chrome ("The site [IP Address] refused to connect")
    • LMS web interface doesn't work (same message as above)
    • the config app can't contact the music server ("SqueezePlay Device; Please activate SSH; Status: Access denied")
    • SSH connections don't happen (Android app on phone; PuTTY)
    • Filezilla won't connect
    But:
    • Windows Explorer can still see, browse and transfer files between the SMB shares on VB2.5
    • "systemctl status sshd.service" (through keyboard/monitor direct connected to VB) reports SSH is active (running) and listening on port 22
    Can anyone suggest where I need to look or what I need to do to get all the components to join up again? I've still got a lot to learn about Linux!
    Last edited by Viragored; 04-18-2020, 06:53 PM.

    Leave a comment:


  • SeanMiddleton
    replied
    Originally posted by radishSB View Post
    I just did the upgrade using the Vortexbox GUI, rebooted, and checked LMS>Settings>Information, which still showed LMS Version as 7.9.1 - 0.7.20180404git1522249619 @ Mon May 14 10:51:59 EDT 2018

    So then I did the update using
    dnf clean all
    dnf update

    I rebooted and checked LMS>Settings>Information, which still showed LMS Version as 7.9.1 - 0.7.20180404git1522249619 @ Mon May 14

    Can anyone think of a reason why the update did not work for me?

    Thanks,

    Steve
    I found dnf very slow. So I implemented the mods here and this made things 100 times faster !! https://www.addictivetips.com/ubuntu...app-installer/

    Leave a comment:


  • garym
    replied
    Just confirming, I tried today (2-22-2020) with a VB 2.4 machine. No update to LMS.

    Leave a comment:


  • radishSB
    replied
    Mr. Bill and bart,

    Thanks for the edit and clarification. Yep, it's probably a case of being patient.

    Cheers,

    Steve

    Leave a comment:


  • bart
    replied
    Well, it seems the rpm's are updated today
    http://yum.vortexbox.org/releases/25/x86_64/RPMS/

    oddly the 24 repos seems to be missing...
    http://yum.vortexbox.org/releases/

    Maybe we just have to wait a bit more ...

    cheers,
    /bart
    Last edited by bart; 02-21-2020, 03:52 PM.

    Leave a comment:


  • Mr. Bill
    replied
    Garym and radishSB, I just checked the Vortexbox repository and noticed that the LMS v7.9.3 update does in fact only apply to those of us using the v2.5 release. The v2.4 release still uses a version of LMS from 04/04/18 as noted above.

    I have edited my original post to reflect this information.

    Bill

    Leave a comment:


  • garym
    replied
    Yep, I didn't update to 2.5, I had a problem and sent my unit back to Andrew and told him to also update to 2.5.

    Leave a comment:


  • radishSB
    replied
    bart,

    Hi. That sounds like a reasonable hypothesis, given I'm still running 2.4 also. To tell you the truth, I'm a little leery of trying the upgrade to 2.5.

    And, garym, thanks for chiming in...I'm interested in seeing what will happen when you try upgrading your 2.4 machine.

    Sigh,

    Steve

    Leave a comment:


  • garym
    replied
    my VB that I updated is 2.5 so maybe that's the difference. I have a 2.4 elsewhere, I'll try this weekend and see what happens.

    Leave a comment:


  • bart
    replied
    Originally posted by radishSB View Post
    I just did the upgrade using the Vortexbox GUI, rebooted, and checked LMS>Settings>Information, which still showed LMS Version as 7.9.1 - 0.7.20180404git1522249619 @ Mon May 14 10:51:59 EDT 2018

    So then I did the update using
    dnf clean all
    dnf update

    I rebooted and checked LMS>Settings>Information, which still showed LMS Version as 7.9.1 - 0.7.20180404git1522249619 @ Mon May 14

    Can anyone think of a reason why the update did not work for me?

    Thanks,

    Steve
    Hello Steve,

    For me it has the same outcome ...

    I'm 'still' on VortexBox SW Version: 2.4
    So maybe that's what's wrong

    cheers
    /bart

    Leave a comment:


  • garym
    replied
    Yep, something off. You should have some info about new LMS package to download.

    Leave a comment:


  • radishSB
    replied
    garym,

    This is all the visible output I got from the GUI interface:

    ---------------------------------------------------------------------------------------------------------------------------
    Click on the VortexBox Upgrade icon (package icon in the lower left) to update the log display.
    02/21/2020 09:27:51 - Upgrade log cleared.

    02/21/2020 09:27:57 - Starting upgrade. (This can take a long time...)

    0 files removed
    Dependencies resolved.
    Nothing to do.
    Complete!
    Last metadata expiration check: 0:00:18 ago on Fri Feb 21 09:31:12 2020.
    Dependencies resolved.
    Nothing to do.
    Complete!
    02/21/2020 09:31:39 - Upgrade complete. Please reboot your VortexBox.
    ---------------------------------------------------------------------------------------------------------------------------

    I'm puzzled; maybe Andrew is doing some tinkering. I'll try again later.

    Steve

    Leave a comment:

Working...
X