Announcement

Collapse
No announcement yet.

Fedora security updates only on newer releases

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Interesting!

    Comment


    • #17
      New update coming. meltdown and spectre require special code to be run on the box. This is virtually impossible on a headless box with no desktop. So we are safe for now.

      Comment


      • #18
        Interesting!

        Comment


        • #19
          Originally posted by agillis View Post
          New update coming. meltdown and spectre require special code to be run on the box. This is virtually impossible on a headless box with no desktop. So we are safe for now.
          Suitably cryptic Andrew! I wouldn't dream of asking on time scales but would be very interested to know: -
          • Which version of Fedora is this likely to end up on?
          • Is there likely to be an "upgrade path" from VB2.4 as there seems to be a current route by invoking the Fedora upgrade as I tested yesterday?
          • Is there any reason why I shouldn't try running a further OS upgrade to Fedora 27?
          • Will the appliance have to be rebuilt once any new VB version is available if anyone has tried the upgrade path that I ran yesterday?
          Having patched the OS and VB yesterday and installed the latest Plex and Bliss versions, running the VB upgrade from the GUI did not try to downgrade anything. I have left the LMS version at 7.9.1 - 0.6.20170928git1508251793 as reported in the LMS server settings web page GUI.

          Anything else you are happy to share with the rest of us would obviously be of interest to us all!

          Thanks for your valuable work on this project over the years.

          Comment


          • #20
            Originally posted by Arcticpollen View Post
            Update: - OK, so I detached my STORAGE drive again and gave it all another go: -
            • Installed VB2.4 from scratch from a bootable USB image.
            • dnf -y update to grab latest updates - ran it twice to make sure. Rebooted.
            • Resized the root partition with config_4-30.sh
            • Installed Plex and Bliss from the VB GUI.
            • Manually installed latest version of Plex from SSH session. Rebooted again.
            • Ran dnf install dnf-plugin-system-upgrade
            • Ran dnf system-upgrade download --refresh --releasever=25
            • Ran dnf system-upgrade reboot
            • Shutdown and reconnected my STORAGE HDD.
            • Edited /etc/fstab to mount my additional HDD as /storage as per the old 2.3 two disk installation instructions.
            • Ran dnf -y update a couple of times more.
            All went fine except that Plex was downgraded but that was an easy fix by re-installing the latest version via DNF install via SSH. Bliss is fine too.

            LMS is fine via my USB DAC on the Oppo.

            Now seem to have Vortexbox 2.5 on Fedora 25... If I get brave tonight, I might try running it up another 2 versions to Fedora 27.

            Thanks for the directions Arcticpollen! The update seems to work well to Fedora 25 & VB 2.5, but upgrading it to Fedora 27 breaks it..VB no longer in the repo and LMS doesn't load.
            I didn't try the mid-step to Fedora 26, I think Andrew has typically gone with the odd number releases, nor did I try to manually install LMS.
            I'll get to testing the Fedora 25/VB 2.5 over the next couple of days on a spare box, and if all goes well, maybe update my main box, with is a 2 disk install, after backing it up, of course...
            Thanks to Andrew for keeping this project moving forward!!

            Comment


            • #21
              Thanks Sully. I didn’t bother trying the onward upgrade towards Fedora 27. My appliance is working well again on 25 with the latest VB version too so I’m happy to wait for future official releases.

              Comment


              • #22
                Decided to follow Articpollen's instructions. All seemed to go as planned until final reboot.
                VB will power on but does not seem to boot. Does not show on my network nor can I access webpage.
                Plugged a monitor into it to see if any error messages were showing.
                All initial processes came up [OK] until these:

                [FAILED] Failed to start Login Service
                See 'systemctl status systemd-login.service' for details
                [OK] Started Permit User Sessions
                [FAILED] Failed to start Network Manager
                See 'systemctl status NetworkManager.service' for details
                [DEPEND] Dependancy failed for Network Manager Wait Online
                [FAILED] Failed to start Avahi mDNS/DNS-SD Stack
                See 'systemctl/status avahi-daemon.service' for details

                Looking at these messages I would assume that there is a networking problem which is why the VB is no longer showing on my network in any way.
                I can connect a keyboard to type in commands to fix if anyone has any suggestions but, at this stage, is a re-install of v. 2.4 the only solution?

                Thankfully I did a full back up first.
                Last edited by GuruPete; 02-01-2018, 01:10 AM.

                Comment


                • #23
                  I'm by no means a Linux expert as I work with Microsoft technologies but I do understand networking pretty well. It looks like something core to the network connection has failed which then causes subsequent system dependencies to fall over. Did you just try the upgrade to Fedora 25? Sully had issues trying to take it to ver 27.

                  If I run
                  Code:
                  systemctl status NetworkManager.service
                  I get: -

                  Code:
                  [[email protected] ~]# systemctl status NetworkManager.service
                  ● NetworkManager.service - Network Manager
                     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
                     Active: active (running) since Wed 2018-01-24 20:23:28 GMT; 1 weeks 0 days ago
                       Docs: man:NetworkManager(8)
                   Main PID: 538 (NetworkManager)
                      Tasks: 3 (limit: 4915)
                     CGroup: /system.slice/NetworkManager.service
                             └─538 /usr/sbin/NetworkManager --no-daemon
                  
                  Jan 24 20:24:25 vortexbox NetworkManager[538]: <info>  [1516825465.8565] manager: NetworkManager state is now CONNECTING
                  Jan 24 20:24:25 vortexbox NetworkManager[538]: <info>  [1516825465.8586] device (eth0): state change: prepare -> config (reason 'none') [40 50 0]
                  Jan 24 20:24:25 vortexbox NetworkManager[538]: <info>  [1516825465.8597] device (eth0): state change: config -> ip-config (reason 'none') [50 70 0]
                  Jan 24 20:24:25 vortexbox NetworkManager[538]: <info>  [1516825465.8637] device (eth0): state change: ip-config -> ip-check (reason 'none') [70 80 0]
                  Jan 24 20:24:25 vortexbox NetworkManager[538]: <info>  [1516825465.8889] device (eth0): state change: ip-check -> secondaries (reason 'none') [80 90 0]
                  Jan 24 20:24:25 vortexbox NetworkManager[538]: <info>  [1516825465.8894] device (eth0): state change: secondaries -> activated (reason 'none') [90 100 0
                  Jan 24 20:24:25 vortexbox NetworkManager[538]: <info>  [1516825465.8896] manager: NetworkManager state is now CONNECTED_LOCAL
                  Jan 24 20:24:25 vortexbox NetworkManager[538]: <info>  [1516825465.9002] manager: NetworkManager state is now CONNECTED_GLOBAL
                  Jan 24 20:24:25 vortexbox NetworkManager[538]: <info>  [1516825465.9005] policy: set 'System eth0' (eth0) as default for IPv4 routing and DNS
                  Jan 24 20:24:25 vortexbox NetworkManager[538]: <info>  [1516825465.9008] device (eth0): Activation: successful, device activated.
                  You should be able to run that command from the screen console rather than via SSH like I did.

                  Comment


                  • #24
                    GuruPete, you may also want to try booting from an older kernel upon rebooting...
                    Suggest running a dnf clean all & then dnf update, but if the network is nonfunctional, then that option isn't there for you

                    I can envision Andrew, if he is reading this, doing a palm plant to his forehead

                    Comment


                    • #25
                      Andrew,

                      Are you able to give us some very rough, indicative, non-committed, guesstimate on when we could expect to see VB 2.5 ? My 2.3 system is a little screwed up and I could go to 2.4 but would rather wait for 2.5 if it is going to appear in the forseeable future.


                      cheers

                      Comment


                      • #26
                        I would like to know too... Anxiously awaiting a new update.

                        Comment


                        • #27
                          Happy to see that my hint raised interest in more than a few and that some interesting findings, including that of an upcoming VB 2.5 release coming soon.

                          Interestingly enough, it is quite easy to check the current status of the RPMS, that is the software packages used by Fedora, on the official repository for Vortexbox which is at:
                          http://yum.vortexbox.org/releases/

                          You will find subdirectories for each Fedora release, and the last active one is for Fedora 25, and that is precisely why Arcticpollen has been able to get a suitable update to VB 2.5

                          In fact, one checks the content of the RPMS directory for Fedora 25:
                          http://yum.vortexbox.org/releases/25/x86_64/RPMS/

                          you will find a number of interesting RPMS including:

                          vb-GUI-2.5-1.fc25.noarch.rpm 14-Feb-2018 10:41 403K RPM package
                          vb-GUI-systemline-2.5-1.fc25.noarch.rpm 14-Feb-2018 10:41 388K RPM package
                          vb-autoripper-1.0-1.fc23.noarch.rpm 14-Feb-2018 10:4 17.1K RPM package
                          vb-startup-1.0-9.fc25.noarch.rpm 14-Feb-2018 10:41 9.1K RPM package
                          vortexbox-2.5-2.fc25.x86_64.rpm 14-Feb-2018 10:41 1.8M RPM package
                          vortexbox-release-3-3.noarch.rpm 14-Feb-2018 10:41 6.4K RPM package

                          Still, this is *only* for Fedora 25 and not for 26 and 27 which are the currently supported versions.

                          The plot indeed thickens...

                          Bye, Luca

                          Comment


                          • #28
                            Way back when 2.3 was on its last gasp I bought a new Mini ITX mobo and attempted to install VB 2,3, only to find that the kernal in the usb did not have support for the network interface on the new mobo so after the installing from the usb the install stopped because the network wouldn't connect to the internet.
                            I bought an Intel network card and plugged that into the mobo and the install went ahead and after a yum update I was able to remove the Intel card and it still works.

                            The next install I tried with 2.3 not only wouldn't recognize the network interface but it also did not recognize the disk controller. As I recall, I was saved by the new 2.4 usb install that had a driver that recognized the disk controller.

                            So the need for an occasional update to the install kit is there for new hardware, not just security patches to the Intel chips.

                            Anyhoo, I'm going to try updating to 2.5 using the instructions from Arcticpollen.

                            I remember one install that I did using an old mobo that wouldn't boot from a usb, by connecting the target system drive to a mobo that would boot from a usb, stopping after the initial install and then connecting to the intended mobo and continuing
                            (http://web.archive.org/web/201701041...rive-as-system)

                            I suspect that technique could be used to get a modern mobo with unrecognized drivers to work if the install is upped to 2.5 before connecting the system drive to the intended mobo.

                            Comment


                            • #29
                              Just updated 2.4 to 2.5. The update overwrote both LMS and Plex, with the result that LMS wouldn't start. Followed the instructions here
                              http://forums.slimdevices.com/showth...l=1#post876596
                              and installed latest LMS 7.9.1 and latest Plex., all working now.

                              Edit: Just upgraded a second box, this one with An Asrock B85M-ITX mobo that has a Qualcomm Atheros AR8171 LAN chip that wouldn't work under VB 2.4 and required a LAN card. After upgrading, I removed the LAN card and enabled onboard LAN in the BIOS, saved and booted and the onboard LAN worked.
                              Last edited by Wirrunna; 02-19-2018, 10:17 PM.

                              Comment


                              • #30
                                Fedora 25 seems to support many more hardware types. VB 2.4 would not install at all on my new Apollo Lake board so had to use the old one to build, upgrade to Fedora 25 and VB 2.5. Swapped the board over and all was well. Looking forward to seeing an official new installation routine at some point.

                                Comment

                                Working...
                                X